Wednesday, 26 August 2009

Fast extruder

I put together my new extruder controller, the worm pulley drive mechanism with the GM17 tiny stepper hack and the stainless steel extruder with heatsink and ducted fan to make possibly the most complicated extruder design yet!

You can see a better view of the drive mechanism fitted on another extruder base here: -

Here is a reminder of what the heater assembly looks like: -

The heatsink is cooled by a tiny fan. When run from 12V it is very noisy and way too powerful. With my new controller I can run it with PWM just a bit faster than its stall speed. That keeps the noise down and still gives more cooling than needed. I attached a thermistor to the heatsink by gluing it into a crimp tag with J-B Weld.

I can tell the controller to keep the temperature below a specified level by turning the fan on and off. I set the trip point to an arbitrary 35°C. It will even turn it on when the extruder is idle, much like the radiator fan of a car runs after the engine is switched off. This is needed to ensure PLA will never soften and jam in the cold part of the tube.

I run the tiny stepper motor at about 300mA to keep it cool enough to touch. It will take more current than that but runs very hot. A good design would use a single fan to cool the motor and the heatsink.

I ran the motor with micro stepping, so even though it has a 15° step, that gives 192 steps per revolution. The GM17 gearbox has a reduction of 228:1 giving a massive 43,776 steps per revolution of the worm pulley. That seems a lot, but the diameter of the pulley is 13mm, so one turn is 40.84mm of feed. That gives 1072 steps per millimetre. In comparison I have been using an 816 step shaft encoder and an 0.8mm pitch thread, which gives 1020 steps per millimetre, almost the same.

I started extruding ABS with my usual feed rate of 16mm/s for 0.5mm filament, which is 3.14 mm3 per second. I kept doubling it until it failed, which was 128mm/s if I have got the calculations right. At that point it mostly worked but something was slipping occasionally. I think it was the clutch in the gearbox. Backing off to 64mm/s it works fine. That is four times faster than the GM3 manages with a screw drive. It is too fast for HydraRaptor but I reckon my Darwin could go that fast. I have no idea what the build quality would be like but it would get the time to print one down to about 24 hours.

Here is a video of it spewing out plastic.

Fast Extruder from Nop Head on Vimeo.

It isn't mechanically compatible with HydraRaptor without making a new bracket to mount it on the z-trolley, so I haven't made anything with it yet.

Monday, 24 August 2009

Time for a new extruder controller

Having decided to switch to stepper drive for my extruder I needed to make a new extruder controller for HydraRaptor, the previous one has served me well for two years.

The spec for the new one is: -
  • I2C or RS485 comms link to the main controller.
  • Micro stepping bipolar stepper drive.
  • Heater control from a thermistor.
  • Fan control output.
  • Second fan control and second thermistor for controlling extruder heatsink temperature.
  • A spare output for a solenoid, etc.
  • A filament empty input.
I designed it in Kicad and got the PCB made professionally. Here is the schematic: -

U4 generates a local 3.3V rail from the 12V supply. C8 and C9 are the bulk low frequency decoupling for the 12V and 3.3V rails respectively. C1, C2, C3, C5, C7, C12 and C13 are the high frequency decouplers placed close to the chips that they are decoupling. D2 is a green LED to indicate the board is powered.

U2 is an RS485 transceiver which I intend to use on my Darwin. It is slew rate limited and ESD protected but somewhat expensive compared to the older 5V versions. R1 ensures the transmitter is off until the micro takes control of it. HydraRaptor uses I2C to talk to its heads at the moment, via K1.

Q3, Q4 Q5 and Q6 are NIF9N05CL protected MOSFETs to control fans, heaters and solenoids, etc. They are protected against over current, over voltage (hence no back EMF diodes), over temperature and ESD. They also have controlled edge rates to minimize RFI. Q1 and Q2, together with R3 and R4, are level translators to increase the gate drive voltage on the two higher current drives. That minimises the on resistance to ensure they stay cool without heatsinks, even at 2A or more. R13 and R14 ensure the drives are off before the micro starts. D6, D7, D8 & D9 are red LEDs to indicate when the outputs are on. Essential for the heater output, but a luxury for the others.

R15, R16, R17 & R18 form the correct potential dividers to give a good approximation to linear temperature response for 10K thermistors, see here for details. For a 100K thermistor they would simply be 10 times bigger. C10 and C11 remove high frequency noise. Probably unnecessary as a little noise actually seems beneficial because it converts bang-bang control to proportional.

The thermistor inputs have their own analogue ground rail, which is only linked to the main ground at one point close to the VSS pin of the MCU. This is done via a zero ohm link, R25, on the schematic. On the PCB this is the smallest footprint available and is shorted by a bit of copper, so no part is actually fitted. The reason for this bodge is to keep the track separate from the ground fill, so that no current from the heater or motors is passing along it. That might cause a small voltage offset that would affect the temperature reading.

U1 is the stepper motor driver. I used the Allegro A3983 as it gives micro stepping with a smaller external part count than the A3977, but as mentioned previously it does have some disadvantages.

C6 and C7 form a charge pump which generates a supply rail for the gate drive that is higher than the main supply voltage (12V). That allows the top transistors of the H-bridges to be N-channel devices, rather than P-channel, which have inferior performance.

R22 sets the off time of the chopper and needs to be different values for different motors as described here.

R23 and R24 are 1W current sense resistors. I found them to be expensive in the 2512 SMT package. It is actually cheaper to use two 1210 0.5W resistors in parallel, or through hole parts mounted vertically, which take up less board area.

The reference voltage for the chopper is generated by a high frequency PWM output on the micro and smoothed to DC by R2 and C4. That allows software control of the motor current. As I had plenty of spare I/O on the micro I also have software control of the step mode (full, half, quarter or eighth), the enable and the reset pin. R5 ensures the stepper is disabled before the micro is running. As with R1 it ensures the circuit is well behaved before the micro is programmed, or when it is being run under a debugger.

D3, D4, D10 and D11 indicate the state of the stepper outputs, a bit of a luxury really. With SMT parts there is not much point in using bi-colour LEDs. It is cheaper to use back to back red and green next to each other.

I used an MSP430F2012 micro on my first extruder controller because you get a full development kit including an excellent C compiler, in circuit programming and source level debugging for $20. I think there is also open source support via gcc, but I have not investigated that yet.

For this one I had to move up to an MSP430F2112 to get a UART for the RS485. As it is the same core with different peripherals I assumed my $20 eZ430 SpyBiWire debugger would still work. Big mistake! It programs OK but it locks up when trying to debug. It also miss-identifies the chip. I have two, and the second one I tried said the firmware needed updating and offered to do it. JUST SAY NO, if you say yes it reprograms the eZ430 and it never talks again. I contacted TI and they have no plans to fix this firmware updating bug so I got an MSP-FET430UIF debugger for $99. It does JTAG as well as SpyBiWire so I should be able to mend my second eZ430, as it has JTAG test points and I read the security fuse is not blown. I also suspect a new eZ430 may well work as the web page has been updated to show it supports the F21x2 now.

D1 and D5 are red and green status lights. I light the green one to show the processor is running and blink it whenever it receives a command. The red one indicates errors.

P3 is a connector for a filament out switch. I haven't implemented one of those yet as a spool of filament usually lasts many months. It uses an internal pullup resistor to pull it high when the switch is open.

P1 is the SpiBiWire connector for programming and debugging.

Even with extravagant motor control I had three spare I/O lines, so I brought them out to a connector with the supply rails for future expansion.

This is what Kicad predicted the populated board would look like: -

I found 3D models for all the parts on the web but the connectors were a bit of a nightmare. I used Tyco MTA100 and MTA156 connectors as they seem to be about the cheapest form of wire to board connector. As usual there is an expensive tool to insert the wires, but you can get away with using a pair of needle nosed pliers, or even make a tool as it is only a metal plate with slots in it mounted in a plastic handle. We should be able to RepRap one.

Tyco have STEP and IGES 3D models on their website. Kicad needs VRML, which should have been no problem as CoCreate can import STEP or IGES and export VRML. But Kicad did not like the VRML from CoCreate, it seems it has to come from Wings3D. Wings can import STL but it does not like the STL from CoCreate or AOI either. In the end I had to do IGES -> CoCreate -> STL -> AOI -> OBJ -> Wings-> VRML -> Kicad! I coloured the body and pins in Wings.

I got five boards made by PCB-Pool in 8 working days for €125 including shipping, certainly not the cheapest, especially as it included Irish VAT at 21.5% (VAT is only 15% at the moment in the UK), but I like the web interface, the quality is good and they include a free solder paste stencil.

They also email pictures of the board being made at five different stages, although two of mine went missing. Here it is before the tin plating was added: -

And here it is finished apart from routing the outline: -

Using the stencil is very easy. You trap the board between two L-shaped pieces of PCB material stuck to a flat surface with some masking tape. You then align the stencil over the pads and stick one edge with masking tape. Spread some solder past along the edge that is stuck and then wipe it across the board with a metal squeegee to force it through the holes and leave it exactly level with the surface of the stencil.

You then lift the stencil carefully from the edge that is not taped down.

Notice how the paste for the heat slug on the A3983 is split into four and reduced in area. This is recommended to stop the chip floating on the paste and sliding across the footprint. It was not easy to do in Kicad. It doesn't seem possible to do it in the component footprint, so I had to draw on the stencil layer of the PCB. That means if I use the chip again I will have to do it again. I had the same limitation when expanding the resist layer around the fiducials. These are the two copper circles bottom left and mid right. They are used for optical alignment of pick and place machines.

The next stage is to place all the parts with tweezers. I used 0805 footprints for all the passives, so they were not too fiddly to do by hand. I hope to be able to automate the pasting and placement with HydraRaptor soon.

Then I cooked the board in a cheap electric oven, a Severin TO 2020 for €45.

I believe you can get these for as little as £15. I expect they give more even heating than using a hotplate, as they heat from above as well as below, but a hotplate has the advantage of taking up a lot less space and probably uses less power. I will be making a heated bed for HydraRaptor, so I might be able to use that.

The temperature profile was controlled by a thermocouple attached to a PID controller that I borrowed from work.

When I have time I will connect one of Zach's thermocouple boards to a spare analogue input on HydraRaptor and plug the oven into the software controlled mains outlet that HydraRaptor has, and then program it as a PID controller. Not another head, but certainly another manufacturing capability. I will also try putting extruded objects through a heat cycle in the oven while they are still attached to the base. It should release the stress so they don't warp further when removed.

This was the finished result after hand soldering the connectors: -

U2 is not fitted because I got the footprint wrong, doh! I can bodge one on when I need RS485. There are two construction faults on this picture, can you spot them?

The reflow was not perfect. The big capacitor did not flow at all. The temperature needs to be a bit higher, or perhaps the warm-up a bit slower. There were solder bridges on the TSSOP chips. That was because you are supposed to shrink the stencil apertures by an amount related to the stencil thickness to get the correct amount of paste. Normally the stencil manufacturer will do that for you but PCB-Pool do not offer it on their free stencils, presumably because they are shared with other designs. Unfortunately Kicad only seems to be able to make them 1:1 with the pads. It is open source, and written in C++, which I know well, so I could have a go at adding that facility if I had the time.

I have tested the board and used it to control one of my experimental extruders, more details tomorrow. The only thing wrong with it apart from the foorprint error is that the A3983 gets too hot to deliver its full rated current of 2A. 1A is no problem, which should be plenty for the extruder designs I have in mind.

The back of the board is nearly all copper to give a good heatsink but at 2A per coil the chip will dissipate 2 × 2A2 × (0.3Ω + 0.3Ω) = 4.8W. The datasheet recommends a 4 layer board with 2oz copper on the outer layers. I am not sure what the extra cost of 2oz is. I will investigate the heat distribution in more detail at some point.

Sunday, 9 August 2009

Black and blue

I got some of the 3M blue masking tape that Vik Olliver recommended as a bed material for PLA. It seems to be available up to 50mm wide, so four strips covers the bed of my machine.

Whereas I could not get PLA to stick reliably to MDF, it sticks easily to the tape.

Why is it black? Well my feed of PLA from the overhead hanging basket snapped. It must have got kinked and bent through too sharp a radius. When I pushed the new end into the top of the extruder to restart it, I must have caught some of the grease from the top bearing. The grease is yellow, but as soon as the stainless steel bearings have run for a while it turns black. That small amount of material was enough to turn the first few layers of my object dark grey.

The object was a complicated shape and came out very hairy: -

It took a lot of cleaning up and has some defects and weak spots where there is a lack of material due to the oozing that occurs on the way there. I have some compensation for this effect, which works well for ABS. Basically I estimate the amount of ooze from the time the extruder is off and then run the extruder for a while to replace it before starting a new thread. I think the constants need to be completely different for PLA.

The object was relatively large, but showed no sign of warping, even when removed from the bed. The base of it is completely flat.

I had successfully removed several small objects but I damaged the tape removing this one. It was easy to replace one strip and reducing the temperature of the first layer from 210°C to 180°C seems to allow large objects to be removed easily.

Another problem I had was the PLA started revolving fairly quickly in the extruder, making the hanging basket spin. Each time it revolves it reduces the amount fed by one thread pitch. If it happens too much the object has material missing. I fixed it by applying some oil to a felt washer that the filament passes through. A good reason for moving to a pinch wheel feed though.

I made a 65mm cube shaped box and it showed no sign of lifting from the bed.

It was easy to remove though and this time did not damage the tape. Even after it was removed the base stayed fairly flat.

Much better than my attempt to make the same box in ABS some time ago.

Not only did it curl after it was removed from the base, it also ripped itself open at the corners while it was being built. There is also a wavy distortion on the left face which I had not encountered before.

I think what happened is that when the cracks opened the edges lifted, causing the nozzle to bear down on the wall it had already built. That meant there was excess plastic for the gap between the surface and the nozzle. Normally when that happens blobs are left on the surface. When the next layer is done the nozzle just plows through the blobs. Because the walls are only 1.5mm thick in this case, and tall, they flexed sideways instead. That caused a ripple and the effect seems to build up layer on layer. I could see the wall flexing as the nozzle passed over it.

So PLA allows bigger objects to be made before a heated bed or chamber becomes necessary.

Even relatively large PLA objects can be made without a raft. That saves a lot of time and material, but you do have to get the z-calibration spot on and the bed perfectly level.

The masking tape makes a good, cheap, reusable bed material and it is quick and easy to replace if you do damage it.

Mixed decay, mixed blessing

Having set the correct off time to suit my motor I can now micro step it with equal spaced steps, but only if I disable the mixed decay mode.

When the chopper switches off it can do it two ways. It can turn on both low side transistors. That short circuits the motor and lets the current recirculate. If the coil was a perfect inductor and the transistors perfect switches, the current would circulate forever and you would have a superconducting magnet. Real coils and transistors have some resistance, which causes the current to decay, but as these are relatively small the mode is called slow decay.

This is fine and efficient until you take the motor's back emf into account. During the rising part of the sine wave the magnet is moving towards the pole piece, so it generates a voltage that causes the current to fall faster. The on time gets longer to compensate and all is well.

On the trailing edge of the sine curve the magnet has gone past the pole piece and generates a voltage that increases the current in the coil. If it is going fast enough it can mean that the current doesn't fall at all during the slow decay period. As I showed previously that can cause a severely distorted waveform which makes the motor noisy.

The Allegro chips offer a mixed decay mode, where they switch to fast decay for part of the chopping cycle on the downward half of the sine curve. In fast decay mode one low side and one high side transistor turn on and reverse the voltage across the motor. That overcomes the BEMF and causes the current to fall much faster. It also returns current to the supply rail, which can upset some power supplies if there isn't some other load to absorb it.

Mixed decay gives a current waveform like this: -

The off time is fixed, so the current falls further making the ripple greater. If you set the percentage fast decay to give a clean waveform at your top speed, then the ripple increases at slower speeds. It is maximum when stationary, when there is no BEMF and fast decay is not required at all.

The problem is that the target current is the trip point of the comparator, so it is the peak of the chopping waveform. That means the average current is less by half the ripple current giving a positional error.

With the low inductance motor I am using, the ripple current has a large amplitude, so the error introduced when the motor is stationary is about the same as a micro step. That means the first step with fast decay is about twice as big as it should be and the last step is virtually zero.

With the A3977 I can disable fast decay and the steps are fairly even, but fast running is then distorted. The PFD setting needs to change with speed.

With the A3983 that I have used on my new extruder controller the PFD setting is fixed at 31.25%. That means I can't get evenly spaced microsteps with the NEMA17's that I have, when running slowly. Not a big problem with the extruder because I plan to gear it down 40:1, which means one micro step is only about 0.02mm. I am only using microstepping to give smooth motion rather than extra resolution.

The problem is exaggerated because not only am I using a low inductance motor, but I am also trying to run it at 1A, whereas it is rated for 2.5A. At 2.5A the off time would be about 2.5 times smaller, so the ripple would be 2.5 times less. The steps in the current waveform would be 2.5 times bigger, so the distortion would be reduced by 6.25 times. As it is about one microstep now, it would reduce to 1/6th of a microstep, so would be acceptable. The temperature rise would then be 6.25 times greater of course.

I was planning to use A3977s for my axis control though, where positional accuracy is important. I am beginning to think I will be better off just using dual H-bridges and doing the rest in software using a powerful micro with a fast ADC.

To be able to cope with a wide variety of motors you need to change the current, the off time setting and the percentage of fast decay. You also need to take the ripple current amplitude into account to control the average current, rather than the peak. All these things could be automated with a software solution.

Thursday, 6 August 2009

Motor Maths

In a previous post I showed the pitfalls of constant off time choppers like the A3977. Basically you have to set the off time long enough to be able to deliver the lowest current step of the microstepping, otherwise the steps are not equally spaced.

Forrest raised the point of how do you do that without a scope. It is fairly easy to calculate from the target current, supply voltage and motor resistance using nothing more complex than Ohm's law. It did take me a few days to come up with a formula that matched my measurements, but that was because I was accidentally running the chip without synchronous rectification enabled.

The motor current is equal to the reference voltage divided by 8 times the sense resistor. The maximum sense voltage is 0.5V, so a sensible value for the sense resistors is 0.2Ω, giving 2.5A maximum with 4V at the reference pin. My lash up uses two 0.5Ω resistors in parallel giving a 2A maximum.

The minimum current required on the first step of the microstep will be I × sin(π/2n), where n is the number of microsteps. In this case n is 8 so the smallest current step is 19.5% of the full current. To calculate the minimum off time needed we need to be able to work out what the duty cycle will be to get a given current.

Here is what the sense resistor waveform looks like when the current is set to 1A and the motor is stationary. The on period is 3μS and the off period is 20μS. The supply voltage is 12V.

The sloping top of the waveform is actually an exponential curve, but at this scale it is very close to linear and to simplify the calculations I have just used the average value.

So we know that 1A flows from the supply for every 3 out of 23μS. That gives an average current from the supply of 1A × 3 /23 = 130mA. Indeed the supply current measures 260mA as there are two coils energised (I set it to full step mode to make this measurement).

When the chopper is on energy flows into the inductance of the motor, increasing its magnetic field slightly. During the off time the current flows in a loop consisting of the motor and the two low side transistors. Power is dissipated by the motor's resistance, so it loses energy by its magnetic field decreasing slightly. We can calculate the duty cycle by reasoning that the energy going in during the on state must equal the energy coming out in the off state.

The motor is a Lin 4118S-62-07 NEMA17 motor I got from Makerbot. It has a coil resistance of only 0.8Ω. That means the resistance of the sense resistor and the on resistance of the FETs in the chip are significant in the calculation.

During the on state current flows through one top transistor, the coil, one bottom transistor and the sense resistor. All the resistances convert electricity to heat so the power going into the magnetic field is the power drawn from the supply minus the resistive losses in the circuit.

Power = VI or I2R, Energy = PT.

So we have (Vsupply × I - I2 × (Rmotor + Rsense + RDS(on) source +RDS(on) sink)) × Ton.

In this example (12 - (0.8 + 0.25 + 0.36 + 0.45)) * 3 = 30.4 μJ.

During the off state the current flows through the motor resistance and two low side transistors, so the energy lost is: I2 × (Rmotor + 2 × RDS(on) sink) × Toff.

In this example (0.8 + 2 × 0.36) × 20 = 30.4 μJ, so theory matches practice (using typical values from the datasheet for RDS(on)), always very satisfying.

So if we call the total resistance in the circuit with the switch on Ron and the total when it is off Roff we have: -
Ron = Rmotor + Rsense + RDS(on) source +RDS(on) sink = 1.86Ω
Roff = Rmotor + 2 × RDS(on) sink = 1.52Ω

Then Toff = Ton (V/I - Ron) / Roff
For our example if we set the minimum Ton (Tblank) to be 1μS, I = 0.195A, so Toff is 39μS.

At 1A Ton will then be ~6μS. So the minimum chopping frequency will be ~22kHz and the maximum will be 25kHz.

CT = Tblank / 1400 = 714pF, so use 680pF.
RT= Toff / CT =58K, so use 62K.

So in conclusion using the simple formulas above it is easy to calculate the correct values for a given motor, supply voltage and minimum current. I wish the datasheet and apps note had included this formula.

Tuesday, 4 August 2009

More PLAying

Way back in April last year I tested a sample of PLA and got as far as making a test block with it and establishing that the warping was much less than the other plastics and you don't need a raft. I finally got round to making some objects with it last week.

The first bed material I used was balsa wood. That works well without a raft. The only downside is that when the object is peeled off it takes a few fibers from the wood with it. No big problem for functional objects, but it does spoil the aesthetic appearance a bit. The top and sides of the object are nice and shiny, but the base is cloudy.

I tried MDF, that gives a smoother finish, but I could not get it to stick reliably. Vik suggested 3M blue masking tape, but I didn't have any to hand, so I tried some sticky back plastic instead. That made objects with a nice glossy base but I could not get the outline to stick reliably.

The lid on the left was made on balsa. I think the black flecks are bits of black ABS which was the last plastic I used in the extruder. The one on the right was made on sticky black plastic. It looks much nicer, but on the top right you can see a bit of missing outline.

I also made this screw-able jewelry box, which looks nice in PLA.

PLA is very nice to extrude. It has a higher melting point than the other plastics but it viscosity falls rapidly with temperature so you can extrude it at lower temperatures. I did the first outline at 210°C, the first layer infill at 200°C and the rest of the object at 180°C. It does not seem critical.

I run the fan after the first layer to make it set quickly. I also needed a fan blowing on the heatsink of my extruder. Otherwise it can heat up past the glass transition of the PLA, which is only about 70°C. When that happens it jams fast and has to be drilled out.

Not needing a raft saves a lot of machine time and also my time removing it.

Even larger objects don't show any warping. I made this contraption to hold a scope probe in place for a job I am doing at work.

Vias are so small nowadays that attaching a wire is difficult and risks ripping the tracks off. Here it is in operation: -